[sanewall-dev] git clone with old git 1.5

Phil Whineray phil at sanewall.org
Sat May 19 09:35:35 CEST 2012


Hi

On 7 May 2012 14:37, Thomas Arendsen Hein <thomas at intevation.de> wrote:
> I noticed that the git repo is available over http only, no git
> protocol. Besides being slow when the repository will grow to
> undreamt of sizes, this prevents access with older git clients.

I believe the http error happens because a newer more efficient git
protocol is in use whereas the older inefficient version has not been
configured.

> Not a huge problem, I mainly wanted to make this post so nobody else
> has to wonder what's wrong when getting the following error message:
>
> error: Unable to get pack index http://git.sanewall.org/sanewall.git/objects/pack/pack-dc7abec3e583a40691688f632d4fdb2d92b65808.idx
> The requested URL returned error: 404
> error: Unable to find 43ff7024712d3d9a6f24b772ef17fe01dbdbf600 under http://git.sanewall.org/sanewall.git
> Cannot obtain needed object 43ff7024712d3d9a6f24b772ef17fe01dbdbf600
> fatal: Fetch failed.

Regardless I have now set up git-daemon so that it is possible to
clone and pull from:
  git://git.sanewall.org/sanewall.git
and
  git://git.sanewall.org/sanewall.git

so older clients should be OK now. Thanks for reporting the problem.

Cheers
Phil



More information about the Sanewall-Dev mailing list